请选择 进入手机版 | 继续访问电脑版
Mozilla

火狐社区

登录    注册

用新浪微博连接 QQ互联

兼容性将给Firefox附加组件带来的改变

yingliu Mozilla员工 发表于 2017-9-18 15:54:53 | 显示全部楼层 [复制链接]
6 5314
本帖最后由 yingliu 于 2017-9-18 15:57 编辑

截图20170918153030.jpg

nightly-logo.fb1ee85824b7.png

Firefox 57 已经在 Nightly(Firefox 每夜版)上线了(还多了个闪亮亮的新标志!)。虽然它现在还不会关闭现有的附加组件(add-ons),但也不会等太久。在我们为Firefox 57 的登场准备之际addons.mozilla.org (AMO)上已展现了不少兼容性功能的变化,以确保后续的转移过程一切顺利。

即将发布的兼容性功能变化
  • 所有的旧型附加组件都将有严谨的兼容性规定,最高可兼容 Firefox 56,而 Firefox 56 也将是支持旧有附加组件的最后一个版本。虽然此类附加组件仍可通过调整默认设置安装于 Nightly 上,但也可能会因 Firefox 的其他变动而失效
  • 由于这个缘故,若附加组件最高版本的设定高于 56,就无法上传
  • 倘若最新版附加组件不兼容,用户将可更轻松地找到较旧的版本。由于有些开发者会提交端口到采用最新 API 技术的 WebExtensions API,所以须将最低版本设为 56.0 57.0。但那会导致使用较低版本 Firefox 的用户找不到兼容版本的附加组件。为了解决此问题,Firefox 将把搜索的兼容性筛选功能默认为关闭。此外,我们也会特别突显含有旧版附加组件的「所有版本」(All Versions)页
  • 未来,以 WebExtensions APIs 开发的附加组件的搜索结果排名会比较高,以避免发生用户安装传统附加组件后,只隔一两周便无法使用的情况

上述变化将在未来几周内陆续推出。

附加组件兼容性是 AMO 最复杂的环节之一,因此,有些东西或许无法一次到位。若您碰到任何兼容性问题,请到此反馈



FlamingFox 老狐狸
发表于 2017-9-18 19:10:15 | 显示全部楼层
我想问一下,我现在所用的附加组件基本上都是老旧版本,能否在56以上的新版本火狐中使用呢?请熟悉的朋友指点一下。
隐元 老狐狸
发表于 2017-9-19 06:32:55 | 显示全部楼层
我支持伟大mozilla带来的创新改变!
yingliu Mozilla员工
发表于 2017-9-19 10:56:38 | 显示全部楼层
FlamingFox 发表于 2017-9-18 19:10
我想问一下,我现在所用的附加组件基本上都是老旧版本,能否在56以上的新版本火狐中使用呢?请熟悉的朋友指 ...

57之后就不能用了。。。。还请尽快找可以替代的附加组件,或等待兼容新版本的附加组件
310971373 狐狸精
发表于 2017-9-20 13:34:51 | 显示全部楼层
论兼容性的重要性
花拳绣腿 狐狸仔
发表于 2017-9-27 09:49:31 | 显示全部楼层
In Speedometer 2.0测试显示,57版本的速度是老版本的2倍,很期待...
绿色圣光 狐狸精
发表于 2017-10-1 12:28:41 | 显示全部楼层
我用的扩展基本都已经完成迁移,或者找到替代品了。除了 DownThemAll! 。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

发新帖
论坛更多 »
热门活动更多 »
  • [免费报名]量子火狐中国社区见面会 Firefox Quantum Fan Meeting[...

    立即参与
火狐微信
快速回复 返回顶部 返回列表