请选择 进入手机版 | 继续访问电脑版
Mozilla

火狐社区

登录    注册

用新浪微博连接 QQ互联

[FAQ] 新版火狐如何使用网银和插件

xuyuehang Mozilla员工 发表于 2017-3-8 09:36:40 | 显示全部楼层   [复制链接]
52 30661
本帖最后由 xuyuehang 于 2017-8-4 10:58 编辑

Q:
更新版本后,原来安装的插件和通过插件实现的功能无法使用。

A:
这是由于 Firefox 在 52 版本中移除了对 Flash 外的 NPAPI 插件支持,包括但不限于一些快速登录插件,邮箱插件,打印机插件,网盘上传插件等。同时有些通过扩展安装上的插件(QQ 邮箱,cntv 等)也都将不能使用。

444065273318F47D3A096DC0CE980391.png

在 52-53 的正式版中,32 位火狐可以通过安装网银支付助手这个扩展暂时解决插件不能使用的问题,由于 55 版本开始官方再次收紧对 NPAPI 插件的支持,原先通过扩展的方式调用已不再被支持,我们提供了两种方式供用户选择:

1.需要使用除网银外的插件
使用 52 ESR 版本,访问官网右侧更多下载中寻找
注意:这将是最后一个支持 NPAPI 插件的版本,ESR 版本的更新仅维持 42 周,建议用户在这段时间里尽快找到插件使用的替代方法。

2.偶尔需要使用网银的用户
安装网银支付助手这个扩展,安装后访问或跳转主流银行网站会看到这个界面:
QQ20170801-0.png

点击“使用 IE 打开”会调起 IE 访问银行网站,如仅浏览网页不进行登录等操作,可以选择继续在 Firefox 中打开。

※ 360 等安全软件可能会在调起 IE 过程中报错,点击忽略即可
关于运行程序的病毒检测可参考:https://www.virustotal.com/en/fi ... e3abbc31e/analysis/

注意:
  • “继续使用 Firefox”会话保持到下次启动浏览器之前,意味着此后在访问相同银行网站时都会在出现这个提示,直到重启火狐。
  • 这个扩展不能使火狐支持其他 NPAPI 插件的调用。

Firefox 移除插件支持的原因是由于原本通过 NPAPI 插件提供的功能,如今已经越来越多的可以通过 Web API 完成。插件导致了很多性能问题,崩溃和各种安全事件。几年前,Firefox 就开始了手动激活插件的过程,允许用户仅在需要时激活插件。其他现代浏览器例如 Google Chrome 和 Microsoft Edge,这些浏览器都已取消了对旧版插件的支持。

新的平台(如 64 位 Firefox for Windows)更是原生不支持插件。

在未来一段时间里 Firefox 将继续支持 Flash,作为插件策略的例外。 Mozilla 和 Adobe 也将改进 Firefox 的 Flash 体验,继续优化稳定性和性能,功能和安全体系结构。
风无迹_ 狐狸精
发表于 2017-3-9 00:19:50 火狐社区移动版 | 显示全部楼层
不错,了解了
向阳阳 狐狸仔
发表于 2017-3-9 20:57:55 | 显示全部楼层
和64版本一样了,之前之所以用32就是插件问题。
明镜缺 狐狸仔
发表于 2017-3-12 13:10:40 | 显示全部楼层
一不小心升级了,然后,我说怎么死都装不上网银插件呢银行那些守旧的插件哪有那么容易与时俱进
Doit的信仰 社区新人
发表于 2017-3-14 11:07:13 | 显示全部楼层
新手请教:firefox3.5+  跟firefox48.2.1 , 这些版本号怎么不是统一的,怎么理解
发表于 2017-3-15 07:11:43 火狐社区移动版 | 显示全部楼层
这个特别好希望大家都来用
艺梦优品 社区新人
发表于 2017-3-16 21:10:42 | 显示全部楼层
没插件的火狐还叫火狐吗???
Meteor 千年狐妖
发表于 2017-3-16 23:43:17 | 显示全部楼层
国内的网银都挂了
请修改用户名 社区新人
发表于 2017-3-17 09:28:06 | 显示全部楼层
建议单独保留一个旧版本

点评

同意你的看法  发表于 7 天前
xuyuehang Mozilla员工
发表于 2017-3-20 14:12:52 | 显示全部楼层
请修改用户名 发表于 2017-3-17 09:28
建议单独保留一个旧版本

可以使用52esr
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

发新帖
论坛更多 »
火狐微信
快速回复 返回顶部 返回列表