请选择 进入手机版 | 继续访问电脑版
Mozilla

火狐社区

登录    注册

用新浪微博连接 QQ互联

移除旧式扩展支持时间表

xuyuehang Mozilla员工 发表于 2018-9-10 17:17:12 | 显示全部楼层 [复制链接]
4 1790
本帖最后由 xuyuehang 于 2018-9-10 17:18 编辑

由于Mozilla在2018年9月5日停止支持Firefox旧式扩展版本(ESR)52的更新,这是支持使用XUL overlay,bootstrapped 和 Add-on SDK 编写的传统扩展的最终版本。所以在此日期之后,任何受支持的Firefox版本都不会兼容旧版附加组件,因此Mozilla将从9月开始在addons.mozilla.org(AMO)上禁用旧版附加组件版本。 2018年9月6日,将禁用新旧版附加版本的提交,所有旧版附加组件版本将于2018年10月初停用,届时用户将无法再在AMO上找到安装的扩展程序。

在禁用旧版扩展之后,开发人员仍然可以将其扩展移植到WebExtensions API。将新版本提交给AMO后,安装旧版本的用户将自动收到更新,那这个扩展又可以重新被启用。

旧式扩展的迁移工作Mozilla已经做了两年有余,是时候迁移到更快的新平台上了。

有关迁移和相关API的介绍可见:wikiMDN


addons.jpg



310971373 狐狸精
发表于 2018-9-11 09:17:02 | 显示全部楼层
图片让我想起了发条地精
翼虎 社区新人
发表于 2018-9-14 18:06:12 | 显示全部楼层
又要和谐掉很多东西啦!!!!!!!!!!!!!!!
FlamingFox 狐狸精
发表于 4 天前 | 显示全部楼层
NoScript有没有WebExtension版本呀?我所收集的扩展基本上都已经有了相应的WE版,就是它没有消息了。
xuyuehang Mozilla员工
发表于 3 天前 | 显示全部楼层
FlamingFox 发表于 2018-9-20 20:39
NoScript有没有WebExtension版本呀?我所收集的扩展基本上都已经有了相应的WE版,就是它没有消息了。 ...

https://addons.mozilla.org/zh-CN ... oscript/?src=search
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表